山东壹加壹金融

当前位置: 网站股票配资 > 股票软件公式 > 同花顺公式 > 文章 当前位置: 同花顺公式 > 文章

同花顺源码:小王追主力,抓妖股,日线资金抄底

点击: 次    来源:顶尖财经    作者:股市狙击 - 小 + 大

1、小王追主力

N:=18; M1:=4; M2:=4;
VAR1:=REF(LOW,1);
VAR2:=SMA(ABS(LOW-VAR1),3,1)/SMA(MAX(LOW-VAR1,0),3,1)*100;
VAR3:=EMA(IF(CLOSE*1.2,VAR2*10,VAR2/10),3);
VAR4:=LLV(LOW,38);
VAR5:=HHV(VAR3,38);
VAR6:=IF(LLV(LOW,90),1,0);
VAR7:=EMA(IF(LOW<=VAR4,(VAR3+VAR5*2)/2,0),3)/618*VAR6;
VAR8:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
VAR9:=SMA(VAR8,13,8);
底线:0,COLOR00FFFF;
主力吸货:VAR7,COLOR0000FF;
吸筹1:STICKLINE(VAR7,0,VAR7,6,0),COLOR0000FF;
吸筹2:STICKLINE(VAR7,0,VAR7,5,0),COLOR6600FF;
吸筹3:STICKLINE(VAR7,0,VAR7,4,0),COLORBB00FF;
吸筹4:STICKLINE(VAR7,0,VAR7,3,0),COLORFF00FF;
吸筹5:STICKLINE(VAR7,0,VAR7,2,0),COLORFF33FF;
吸筹6:STICKLINE(VAR7,0,VAR7,1,0),COLORFF66FF;
吸筹7:STICKLINE(VAR7,0,VAR7,0,0),COLORFF99FF;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:SMA(RSV,M1,1),colorgreen,LINETHICK1;
D:SMA(K,M2,1),COLOR0066FF,LINETHICK2;
J:3*K-2*D,COLORFFCC00,LINETHICK1;
DRAWICON(CROSS(J,K),K,26);
DRAWICON(CROSS(90,J),J,2);
零位线:-0.00,POINTDOT,COLORFFCC00,LINETHICK3;
低位线:-10.00,POINTDOT,COLORFFCC00,LINETHICK3;



2、抓妖股

VAR1:=HHV(HIGH,9)-LLV(LOW,9);

VAR2:=HHV(HIGH,9)-CLOSE;
VAR3:=CLOSE-LLV(LOW,9);
VAR4:=VAR2/VAR1*100-70;
VAR5:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VAR6:=(2*CLOSE+HIGH+LOW)/4;
VAR7:=SMA(VAR3/VAR1*100,3,1);
VAR8:=LLV(LOW,34);
VAR9:=SMA(VAR7,3,1)-SMA(VAR4,9,1);
VAR10:=IF(VAR9>100,VAR9-100,0);
VAR11:=HHV(HIGH,34);
VAR12:=EMA((VAR6-VAR8)/(VAR11-VAR8)*100,13);
VAR13:=EMA(0.667*REF(VAR12,1)+0.333*VAR12,2);
STICKLINE(VAR12-VAR13>0,VAR12,VAR13,6,0),colorred;
STICKLINE(VAR12-VAR13<0,VAR12,VAR13,6,0),COLOR00FF0F;
生命线:EMA(VAR13,5),LINETHICK1;
买:CROSS(VAR12,VAR13) AND VAR12>VAR13,NODRAW,colorred;
卖:CROSS(VAR13,VAR12) AND VAR12<VAR13,NODRAW,colorgreen;
IF(生命线>=REF(生命线,1),生命线,DRAWNULL),colorred,LINETHICK1;
波段买入:IF(CROSS(VAR12,生命线),15,0),coloryellow,LINETHICK1;
波段卖出:IF(CROSS(生命线,VAR12),85,100),LINETHICK1;




3、日线资金抄底

下跌阶段看“手”就下手;震荡或向上阶段看“脸”下手,或股价已上涨。( 顶尖财经 股民学院: http://zxpz69.cn )

强势股【次新股第4坑可】看这张脸,普通股看▼底1PRO的脸。
手、脸对昨天,箭头对当天。

IF(PERIODNAME<>"日线")
{
统计:"该指标只在日线周期下有效。";
RETURN;
}
//大单净量
r:=((ZDMR[-1]+BDMR[-1])-(ZDMC[-1]+BDMC[-1]))/SHGZG*100;
//相对强弱
LC := REF(CLOSE,1);//前一日收盘价;
RSI$1:=SMA(MAX(CLOSE-LC,0),3,1)/SMA(ABS(CLOSE-LC),3,1)*100;
RSI$2:=SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100;
RSI$3:=SMA(MAX(CLOSE-LC,0),8,1)/SMA(ABS(CLOSE-LC),8,1)*100;
相对强弱:=0.5*RSI$1+0.31*RSI$2+0.19*RSI$3;
wave$1:=SMA(100*(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8)),3,1);
wave$2:=SMA(100*(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8)),5,1);
wave$3:=SMA(100*(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8)),8,1);
短线波段:=0.5*wave$1+0.31*wave$2+0.19*wave$3;
机会区:20,POINTDOT,colorred;
风险区:80,POINTDOT,colorgreen;
风险系数:0.5*相对强弱+0.5*短线波段,coloryellow;
//买入条件;
CD1:=IF(风险系数<20 AND CLOSE>OPEN AND r>0,1,0);//波段小于20,股价翻红;
CD2:=IF(风险系数<20 AND LOW>=REF(LOW,1) AND CLOSE>LOW AND r>0,1,0);//波段小于20,股价未翻红,但未创新低;
CD3:=IF(REF(风险系数,1)<20 AND 风险系数>REF(风险系数,1),1,0);//前一日波段小于20,今日转向;
SIGNALBUY=(CD1=1 OR CD2=1 OR CD3=1);
X=(SIGNALBUY AND COUNT(SIGNALBUY,3)=1);
DRAWICON(X,机会区,11);
//buy 2;
机会区xx:32.99,POINTDOT,colorwhite;//之前24,改为25.99,改为32.99
CDxx1:=IF(风险系数<32.99 AND 风险系数>=20 AND CLOSE>OPEN AND r>0,1,0);//波段小于20,股价翻红;
CDxx2:=IF(风险系数<32.99 AND 风险系数>=20 AND LOW>=REF(LOW,1) AND CLOSE>LOW AND r>0,1,0);//波段小于20,股价未翻红,但未创新低;
CDxx3:=IF(REF(风险系数,1)<32.99 AND REF(风险系数,1)>=20 AND 风险系数>REF(风险系数,1),1,0);//前一日波段小于20,今日转向;
SIGNALBUYxx=(CDxx1=1 OR CDxx2=1 OR CDxx3=1);
Xxx=(SIGNALBUYxx AND COUNT(SIGNALBUYxx,3)=1);
DRAWICON(Xxx,机会区xx,5);
 

上一篇:同花顺源码:超买超卖,庄家顶底自己用,主力散户仓位操作线

下一篇:同花顺公式下载:寻龙诀壹式,寻找买卖点 红色买入 黄色卖出