山东壹加壹金融

当前位置: 网站股票配资 > 股票软件公式 > 同花顺公式 > 文章 当前位置: 同花顺公式 > 文章

同花顺源码:超买超卖,庄家顶底自己用,主力散户仓位操作线

点击: 次    来源:顶尖财经    作者:股市狙击 - 小 + 大

1、超买超卖

N:=60;
H1:=MAX(DYNAINFO(3),DYNAINFO(5));
L1:=MIN(DYNAINFO(3),DYNAINFO(6));
P1:=H1-L1;
阻力:=L1+P1*7/8,colorgreen;
支撑:=L1+P1*0.5/8,colorred;
中线:=(支撑+阻力)/2,colorwhite,POINTDOT;
V11:=3*SMA((C-LLV(L,N))/(HHV(H,N)-LLV(L,N))*100,5,1)-2*SMA(SMA((C-LLV(L,N))/(HHV(H,N)-LLV(L,N))*100,5,1),3,1);
趋势线:EMA(V11,3),LINETHICK2,colorlimagenta;
V12:=(趋势线-REF(趋势线,1))/REF(趋势线,1)*100;
超买区:STICKLINE(趋势线<10,趋势线,10,5,0),coloryellow;
DRAWTEXT(BARSLASTCOUNT(趋势线<10)=1,16,'超卖区'),coloryellow;
AA:=(趋势线<11) AND FILTER((趋势线<=11),15) AND C<中线;
BB0:=REF(趋势线,1)<11 AND CROSS(趋势线,11) AND C<中线;
BB1:=REF(趋势线,1)<11 AND REF(趋势线,1)>6 AND CROSS(趋势线,11);
BB2:=REF(趋势线,1)<6 AND REF(趋势线,1)>3 AND CROSS(趋势线,6);
BB3:=REF(趋势线,1)<3 AND REF(趋势线,1)>1 AND CROSS(趋势线,3);
BB4:=REF(趋势线,1)<1 AND REF(趋势线,1)>0 AND CROSS(趋势线,1);
BB5:=REF(趋势线,1)<0 AND CROSS(趋势线,0);
BB:=BB1=1 OR BB2=1 OR BB3=1 OR BB4=1 OR BB5=1;
买:CROSS(趋势线,10);
DRAWTEXT(CROSS(趋势线,10),趋势线,'★买'),colorred;
超卖区:STICKLINE(趋势线>90,趋势线,90,5,0),colorcyan;
DRAWTEXT(BARSLASTCOUNT(趋势线>90)=1,84,'超买区'),colorcyan;
CC:=(趋势线>89) AND FILTER((趋势线>89),15) AND C>中线;
DD0:=REF(趋势线,1)>89 AND CROSS(89,趋势线) AND C>中线;
DD1:=REF(趋势线,1)>89 AND REF(趋势线,1)<94 AND CROSS(89,趋势线);
DD2:=REF(趋势线,1)>94 AND REF(趋势线,1)<97 AND CROSS(94,趋势线);
DD3:=REF(趋势线,1)>97 AND REF(趋势线,1)>99 AND CROSS(97,趋势线);
DD4:=REF(趋势线,1)>99 AND REF(趋势线,1)<100 AND CROSS(99,趋势线);
DD5:=REF(趋势线,1)>100 AND CROSS(100,趋势线);
DD:=DD1=1 OR DD2=1 OR DD3=1 OR DD4=1 OR DD5=1;
DRAWTEXT(CROSS(90,趋势线),90,'★卖'),colorgreen;
顶:90,colorgreen;
底:10,colorred;
中:50,POINTDOT,colorwhite;
DRAWTEXT(ISLASTBAR,顶,'顶'),colorgreen;
DRAWTEXT(ISLASTBAR,底,'底'),colorred;
DRAWTEXT(ISLASTBAR,中,'中'),colorwhite;
 



2、庄家顶底自己用

短线成本:=EMA(CLOSE,17),LINETHICK2,colorwhite;

A:=(3*C+L+O+H)/6;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210;
中线成本:=EMA(X,13),LINETHICK2,COLORFF00FF;
STICKLINE(BARSLAST(短线成本<中线成本)>30,95,100,5,0),colorred;
STICKLINE(BARSLAST(短线成本>中线成本)>30,0,5,5,0),colorgreen;
VAR1:=1;
VAR2:=LLV(LOW,10);
VAR3:=HHV(HIGH,25);
N1:=5;
N4:=34;
CQ:=100*(C-LLV(L,N4))/(HHV(C,N4)-LLV(L,N4));
SAT:=(AMOUNT/C)/(HHV(AMOUNT,N4)/HHV(C,N4));
饱和度:=IF(SAT>1,1,SAT)*100;
W1:=C=HHV(C,20);
W2:=BARSLAST(W1);
W3:=IF(W2>0,REF(C,W2),REF(C,W2));
W4:=CROSS(C,REF(W3,1));
STICKLINE(饱和度>=97 AND CQ>90,0,100,2,0),colorred;
中期:=100*(C-LLV(L,N4))/(HHV(C,N4)-LLV(L,N4));
持股:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
支撑:=LLV(持股,3);
短期线:EMA((CLOSE-VAR2)/(VAR3-VAR2)*4,4)*VAR1*30,LINETHICK2,colormagenta;
中期线:MA(持股,12),colorblue,LINETHICK2;
底部线:0,colorwhite;
警戒线:85,coloryellow;
卖出线:100,colorred;
DRAWTEXT(CROSS(短期线,中期线),短期线,'B');
DRAWTEXT(短期线>90,短期线,'S');
DRAWICON(CROSS(短期线,中期线),短期线,1);
DRAWICON(CROSS(中期线,短期线),中期线,2);



3、主力散户仓位操作线( 顶尖财经 股民学院: http://zxpz69.cn )

M:=60;
N:=30;
VAR2:=REF(LOW,1);
VAR3:=SMA(ABS(LOW-VAR2),3,1)/SMA(MAX(LOW-VAR2,0),3,1)*100;
MTR:=EMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,
1))),ABS(REF(CLOSE,1)-LOW)),21);
VAR4:=EMA(IF(CLOSE*1.3,VAR3*10,VAR3/10),3);
VAR5:=LLV(LOW,30);
HD:=HIGH-REF(HIGH,1);
LD:=REF(LOW,1)-LOW;
VAR6:=HHV(VAR4,30);
VAR7:=IF(MA(CLOSE,58),1,0);
DMP:=EMA(IF(HD>0 AND HD>LD,HD,0),21);
DMM:=EMA(IF(LD>0 AND LD>HD,LD,0),21);
VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;
VAR9:=IF(VAR8>100,50,VAR8);
主力线:DMP*100/MTR;
散户线:DMM*100/MTR;
AA3:=(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21))*100-10;
AA4:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
AA5:=SMA(AA4,13,8);
主力仓位:(主力线-散户线)*1000,COLORSTICK,LINETHICK2;
ZL:主力仓位;
散户线2:100*(HHV(HIGH,M)-CLOSE)/(HHV(HIGH,M)-LLV(LOW,M)),LINETHICK2;
STICKLINE(ZL AND ZL>=0,ZL,0,5,0),colorred;
STICKLINE(ZL AND ZL<0,ZL,0,5,0),colorgreen;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,5,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
DRAWICON(CROSS(ZL,0),-100,1);
DRAWICON(CROSS(0,ZL),100,2);
主力线2:EMA(J,6),COLOR00FF00,LINETHICK3;
操作线2:CEILING(SMA(AA5,13,8)),colorred,LINETHICK2;

上一篇:同花顺源码:紫气东来,初级抄底,多空趋势

下一篇:同花顺源码:小王追主力,抓妖股,日线资金抄底