山东壹加壹金融

当前位置: 网站股票配资 > 股票软件公式 > 同花顺公式 > 文章 当前位置: 同花顺公式 > 文章

同花顺源码:紫气东来,初级抄底,多空趋势

点击: 次    来源:顶尖财经    作者:股市狙击 - 小 + 大

1、紫气东来

趋势1:(5)*(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1))-(3)*(SMA(SMA(((CLOSE-LLV(LOW,27))

/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1),3,1))-SMA(SMA(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1),3,1),2,1),colormagenta,LINETHICK3;
VARA1:=((CLOSE>=REF(CLOSE,1)) AND (REF(CLOSE,1)>=REF(CLOSE,2)) AND (REF(CLOSE,1)<=REF(CLOSE,3))
AND (REF(CLOSE,2)<=REF(CLOSE,3)) AND ((REF(CLOSE,4)>REF(CLOSE,2)) OR (REF(CLOSE,4)<=REF(CLOSE,2))
AND (REF(CLOSE,5)>=REF(CLOSE,3))) OR (CLOSE>=REF(CLOSE,1)) AND (REF(CLOSE,1)<=REF(CLOSE,2))
AND (CLOSE>=REF(CLOSE,2)) AND ((REF(CLOSE,3)>REF(CLOSE,1)) OR(REF(CLOSE,3)<=REF(CLOSE,1)) AND (REF(CLOSE,4)>=REF(CLOSE,2)))),colormagenta,LINETHICK3;
VARB2:=((CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10)))*(100);
VARB3:=EMA(VARB2,7);
VARB4:=EMA(VARB3,10);
VARB5:=(3)*(VARB3)-(2)*(VARB4);
VARB6:=EMA(VARB5,5);
探底:=IF((趋势1<=5),58,0),COLORFF00FF;
桥1:=EMA(VARB6,1);
美化:=IF(REF((COUNT((桥1<=REF(桥1,1)),5)=5),1) AND (桥1>REF(桥1,1)),10,0);
STICKLINE(美化 AND 探底,0,15,15,0),colorliblue;
STICKLINE(美化 AND 探底 ,15,35,10,0),coloryellow;
STICKLINE(美化 AND 探底,35,55,8,0),colorred;
STICKLINE(美化 AND 探底,55,75,6,0),colorff0099;
DRAWTEXT(美化 AND 探底,115,'紫'),colorred;
DRAWTEXT(美化 AND 探底,100,'气'),colorred;
DRAWTEXT(美化 AND 探底,85,'东'),colorred;
DRAWTEXT(美化 AND 探底,70,'来'),colorred;
PARTLINE(IF(C,0,0),2,colorffaacc),LINETHICK3;


2、初级抄底

可以看个股波动,看看K线走势,灵活掌握个股走势。( 顶尖财经 股民学院: http://zxpz69.cn )

 H1:=MAX(DYNAINFO(3),DYNAINFO(5));

L1:=MIN(DYNAINFO(3),DYNAINFO(6));
P1:=H1-L1;
阻力:=L1+P1*7/8;
支撑:=L1+P1*0.5/8;
中线:=(支撑+阻力)/2;
V11:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
趋势线:=EMA(V11,3);
BB1:=REF(趋势线,1)<11 AND REF(趋势线,1)>6 AND CROSS(趋势线,11);
BB2:=REF(趋势线,1)<6 AND REF(趋势线,1)>3 AND CROSS(趋势线,6);
BB3:=REF(趋势线,1)<3 AND REF(趋势线,1)>1 AND CROSS(趋势线,3);
BB4:=REF(趋势线,1)<1 AND REF(趋势线,1)>0 AND CROSS(趋势线,1);
BB5:=REF(趋势线,1)<0 AND CROSS(趋势线,0);
BB:=BB1=1 OR BB2=1 OR BB3=1 OR BB4=1 OR BB5=1;
下单买入:STICKLINE(BB=1 AND C<中线,11,50,3,0);



3、多空趋势

N:=15;

M:=29;
V1:=(C*2+H+L)/4*10;
V2:=EMA(V1,13)-EMA(V1,34);
V3:=EMA(V2,5);
V4:=2*(V2-V3)*5.5;
V11:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,
1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
趋势线:=EMA(V11,3);
VAR1F:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
多方趋势: (7*SMA((CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*30,4,
1)-3*SMA(SMA((CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*30,4,1),3,
1)-SMA(SMA(SMA((CLOSE-LLV(LOW,18))/(HHV(HIGH,
18)-LLV(LOW,18))*30,4,1),3,1),2,1)),COLOR2424FF;
空方趋势: EMA(MA(多方趋势,4),7),LINETHICK1,COLOR1AFF1A;
VAR20:=REVERSE(VAR1F);
VAR21:=SMA(VAR1F,3,1);
STICKLINE(多方趋势<空方趋势,多方趋势,空方趋势,8,0),COLORCECE00;
STICKLINE(多方趋势<空方趋势,多方趋势,空方趋势,4,0),COLORFFFF00;
AA:(趋势线<=13) AND FILTER((趋势线<=13),15);
主力进:IF(V4>=0,V4,0);
V11:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,
1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
STICKLINE(多方趋势<空方趋势,多方趋势,空方趋势,2,0),COLORFFFF3C;
STICKLINE(空方趋势<14 AND 空方趋势>多方趋势,多方趋势,0,10,0),COLOR00D9D9;
趋势线:=EMA(V11,3);
移动平均: SMA(VAR21,3,1), colorred;
STICKLINE(空方趋势<14 AND 空方趋势>多方趋势,多方趋势,0,4,0),COLOR06FFFF;
STICKLINE(空方趋势<14 AND 空方趋势>多方趋势,多方趋势,0,2,0),COLOR3CFFFF;
见顶清仓:FILTER(趋势线>90 AND 趋势线<REF(趋势线,1) AND 主力进<REF(主力进,1),8);
VARA:= EMA(0.667*REF(多方趋势,1)+0.333*多方趋势,2);
参考线: SMA(移动平均,3,1),colorcyan;
V11:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,
1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
STICKLINE(多方趋势>VARA,多方趋势,VARA,8,0),COLOR0000C6;
趋势线:=EMA(V11,3);
走势线:SMA(移动平均,2,1),colorwhite;
趋势线>90 AND 趋势线>REF(趋势线,1);
STICKLINE(多方趋势>VARA,多方趋势,VARA,4,0),COLOR0000FF;
STICKLINE(多方趋势>VARA,多方趋势,VARA,2,0),COLOR3C3CFF;
关注: IF(CROSS(移动平均,参考线) AND 移动平均<30,33,0),coloryellow,LINETHICK2;

上一篇:同花顺源码:阿宝精准买卖点,量变,荣耀短波搏庄看盘

下一篇:同花顺源码:超买超卖,庄家顶底自己用,主力散户仓位操作线